Virtuoso Enterprise - default password


#1

Hi,

I have installed the latest version of Virtuoso Enterprise AWS image, and I’m trying to login to conductor. I try the default dba password, but I get ‘Invalid Credentials’. I also try to change the dba password with isql CLI, but get the below error. On prior login attempts, my browser auto-fill entered the wrong creds. Is the dba account locked out?

image

*** Error 28000: VD CL034: Bad login
in lines 1-2 of Top-Level:
#line 1 "(console)"
set password dba ************

-sherman


#2

The Virtuoso PAGO EC2 AMIs use the instance-id of the AMI as the “dba” user password by default as detailed in the documentation


#3

Thanks for the documentation reference. I restarted Virtuoso using the cmd provided in the doc, then I copy the “Instance Id” value for the Virtuoso AMI from the AWS console and paste it into the password field for the Conduct UI, enter ‘dba’ as the user, and I get “Invalid Credentials”.


#4

You initially asked whether the dba account was locked out – this is possible, if you made several login attempts with the wrong credentials in a short period. The lockout period is not terribly long (I believe it’s five minutes, but it might be a bit longer or shorter), and you can re-attempt login with the credentials now expected to be correct.

Please confirm exactly which AMI you’re running, and refer to the associated documentation page for troubleshooting (as they do vary somewhat) –

If it’s one of the latter two (i.e., not the DBpedia Snapshot), and you have really just instantiated this AMI (i.e., you haven’t made any changes to the DB content), the easiest way to get to a known database state is to simply stop the Virtuoso instance, drop (or move, if you want to preserve it for further analysis and/or later experimentation) the current virtuoso.db file, and relaunch the instance (being sure to force the same virtuoso.ini, so either using the built-in launch scripts, or explicitly including -c /opt/virtuoso/database/virtuoso.ini in your launch command), such that a fresh DB file is created, which will have the ultimate Virtuoso defaults (i.e., the dba user will have password dba).


#5

Thank you Ted, I will give this a try…


#6

I created a fresh instance, and repeated the installation steps. When I visit the conductor, a 404 error is returned.

I verify that the security group exists for port 8890 (I do get the default homepage)

I checked conductor on port 80 also, but browser says “Connection refused”

-sherman


#7

Ah, this is a different issue.

The empty DB doesn’t have the Conductor VAD installed.

If the VAD(s) are already in the filesystem (as I believe to be the case), you can use iSQL to install the Conductor (or any other VAD) with a command like –

vad_install ('file/system/path/package-name.vad', 0);

– so the default would be –

vad_install ('/opt/virtuoso/vad/conductor_dav.vad', 0);

If the VADs aren’t in your AMI’s filesystem, you can download the latest Conductor VAD here. That and all other prebuilt VADs for Virtuoso 8.2 are in this repository.

Generally speaking, we suggest putting these into /opt/virtuoso/vad/, which should already be in the DirsAllowed setting in the virtuoso.ini, for installation as and when you wish.

After this, you should have the normal Conductor interface.


#8

Thank you, that worked! The Conductor login is now showing, and using the AMI ID as the password, I am able to login to the dba account.

-sherman


#9

Now I get the following error when I attempt to install FCT service. I followed the instructions there, then attempted it again, and get the same error:


#10

When I try fct_dav.vad install through isql, I get the following:

SQL> vad_install ('/opt/virtuoso/vad/fct_dav.vad', 0);
SQL_STATE     SQL_MESSAGE
LONG VARCHAR  VARCHAR
_______________________________________________________________________________


Warning 01004: VD CL077: Data truncated in column 2 of the result-se(SQL_MESSAGE, type 182)
at line 2 of Top-Level:
vad_install ('/opt/virtuoso/vad/fct_dav.vad', 0)
S0002         SQ200: No table DB.DBA.SYS_HTTP_SPONGE
while executing the following statement:
--no_c_escapes-
#pragma line 1 "/DAV/VAD/fct/cl_prx.sql"
--
--  $Id$
--
--  This file is part of the OpenLink Software Virtuoso Open-Source (VOS)
--  project.
--
--  Copyright (C) 1998-2016 OpenLink Software
--
--  This project is free software; you can redistribute it and/or modify it
--  under the terms of the GNU General Public License as published by the
--  Free Software Foundation; only version 2 of the License, dated June 1991.
--
--  This program is distributed in the hope that it will be useful, but
--  WITHOUT ANY WARRANTY; without even the implied warranty of
--  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
--  General Public License for more details.
--
--  You should have received a copy of the GNU General Public License along
--  with this program; if not, write to the Free Software Foundation, Inc.,
--  51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
--

--DB.DBA.VHOST_REMOVE (lpath=>'/proxy');
--DB.DBA.VHOST_DEFINE (lpath=>'/proxy', ppath=>'/SOAP/Http/EXT_HTTP_PROXY_1', soap_user=>'PROXY',
--      opts=>vector('url_rewrite', 'ext_http_proxy_rule_list1'));

create procedure
ext_http_proxy_1 (in "url" varchar := null,
                in exec varchar := null,
                in header varchar := null,
                in "force" varchar := null,
                in "output-format" varchar := null,
                in get varchar := 'soft',
                in login varchar := '') __SOAP_HTTP 'text/html'
{
  --pl_debug+
  declare hdr, content, req_hdr any;
  declare ct any;
  declare stat, msg, metas, accept, rset, triples, ses, arr any;
  declare local_qry integer;
  local_qry := 1;

  declare params any;
  params := http_param ();

  if (0 and exec is not null)
    {
      ext_http_proxy_exec_qry (exec, params);
      return '';
    }

  req_hdr := null;

  if (header is not null)
    req_hdr := header;

  arr := rfc1808_parse_uri ("url");
  arr[5] :=
00000         GUI is accesible via http://host:port/fct
00000         Post-installation guide is available from http://host:port/fct/post_install.html
42S02         SR136: Bad table name in GRANT / REVOKE DB.DBA.SYS_HTTP_SPONGE.
while executing the following statement:
--no_c_escapes-
grant select on DB.DBA.SYS_HTTP_SPONGE to "SPARQL_SELECT"
in file:
/DAV/VAD/fct/grants.sql
00000         Errors detected
00000         Installation of "Faceted Browser" was unsuccessful.
BLOB 0 chars  The installation of this VAD package has failed.
BLOB 0 chars  Please delete the transaction file /opt/virtuoso/database/virtuoso.trx
BLOB 0 chars  and then restart your database server.
BLOB 0 chars  Note: Your database will be in its pre VAD installation state after you restart.
00000         FATAL
BLOB 0 chars  

*** Error 08S01: VD CL065: Lost connection to server
at line 2 of Top-Level:
vad_install ('/opt/virtuoso/vad/fct_dav.vad', 0)

I have the FCT UI, however. Is there a test I can perform to know it’s ok and stable, other than loading some data and attempting a query:


#11

The FCT service seems to be working okay.


Can't log into Conductor