Virtuoso Enterprise - default password

I did that,

  1. wget
  2. tar -xvf lovpz2zz.tar
  3. sh ./
  4. bin/
  5. cat database/.initial-password

but there is no password appear, it show as image below


Can you confirm what Linux distribution and version is being used?

Also provide the version of curl on your system (curl --version).

It seems there is something strange going on with your system that is causing this behaviour which running the script, which we need to look into but need the information requested above.

In the meantime, with your current installation, you can start an empty database with default dba pwd as follows:

  1. Kill the currently running Virtuoso instance with the commands:
    ps -ef | grep virt   ;;; to determine the PID
    kill -9 <PID>
  2. From the Virtuoso installation directory, run the following command to set up the Virtuoso environment :
    . ./
  3. Go to to the database directory and run the following commands to remove the current database:
    rm .initial-password virtuoso.lck virtuoso.trx virtuoso.db
  4. From the database directory, run the command –
    – which will start a new empty database with the default dba password. You can check the virtuoso.log file to confirm the database started successfully

Hi @hwilliams
I applied them, now it works,
Thanks a lot.

Good to hear this is working for you, but would still like to have the details of your Linux distro and curl version as requested previously, so we can look into possible cause of the issue with the script you encountered?

Hi @hwilliams,

Im using Debian GNU/Linux 9 (Debian 4.9.168-1+deb9u5) and version of curl is curl 7.52.1 (x86_64-pc-linux-gnu).


Line 202 of the Virtuoso installation ~/installer/ script is the source of the problem:

PW=`/usr/bin/curl --silent --connect-timeout 1 2>/dev/null`

If you amend this line by adding the curl --fail option, i.e. –

PW=`/usr/bin/curl --silent --fail --connect-timeout 1 2>/dev/null`

– this should resolve the problem with the new installation using he script.

It appears that a machine with IP address exists on your network which happens to have an HTTP web server running on it (which AWS networks use for returning metadata about AMI instances), but the page being requested does not exist, resulting in the 404 ... error being returned (rather than the expected ami-id), which then gets written to the .initial-password file. The --fail option prevents this from occurring, as it forces the actual 404 error state to be returned, rather than “0” which indicates successful retrieval.

This fix is being applied to the installer scripts …

Thank you,
I did it. All things is ok.


3 posts were split to a new topic: Insert weight value for triple