How to install an old version of a VAD

vad
fct

#1

Is there anywhere I can get a version of fct_dav.vad, compatible with Virtuoso Version: 07.20.3217?

This answer helped me install the FCT VAD. It worked fine using Virtuoso Version: 07.20.3229 Build: Nov 13 2018. My problem is that now I need to use Version: 07.20.3217 Build: Jun 2 2016.

When I go to conductor on Version: 07.20.3217 and try to install FCT I get:

The Faceted Browser package requires server version 07.20.3226 or greater

The license_generator on shop.openlinksw gives me fct Version: 1.17_git13/ 2018-10-27, which is incompatible with older versions of virtuoso.

I had a look at the git releases. It seems that the fct source is tracked in binsrc/fct, but I can’t seem to find a tag that matches Version: 07.20.3217 Build: Jun 2 2016.

Is there a way to install an old version of the fct package compatible with virtuoso Version: 07.20.3217? Preferably without having to build from source!

P.s. Sorry for the lack of links, new users are limited to 2 per post :frowning:

Thanks in advance,
Conor


Html views for rdf subjects in virtuoso-opensource
#2

Are you running Virtuoso Enterprise Edition, or Virtuoso Open Source? If you’re not sure, it’s best to provide the first section of output from virtuoso-t -? or virtuoso-iodbc-t -?

In either case, is there a reason you cannot update your Virtuoso 07.20.3217 binary to the current version, as these updates are strongly recommended for all users?


#3

After reading over your previous thread, it seems certain you’re running VOS (the Open Source Edition) v7.2, so you need this FCT VAD built for VOS v7.2.

Any other prebuilt VADs you want to install on that VOS 7.2 instance should be downloaded from this VOS 7.2-focused area.

(The VAD you were previously pointed to, as with all VADs currently available through that download system, were built for the latest Enterprise Edition, v8.2.)


#4

That’s exactly what I needed, thank you!
Apologies for the late reply, I was off for the holidays.