Html views for rdf subjects in virtuoso-opensource


Kingsley Idehen recommended I cross post this from the virtuoso-users mailing list.

Hi all,

I’m new to virtuoso. I have a sparql enpoint I’d like to add html views to.

What I mean is that when I run a query I get a table of URIs, but none of them resolve to a webpage. I get

Error HTTP/1.1 404 File not found

The requested URL was not found URI = ‘/place/411’

All dbpedia URIs resolve to html page, and I’d like my endpoint to behave the same way.

Can this be done in virtuoso itself?
Or do I need to install the facet browser?
Or some other third party tool?

Thanks in advance,

How to install an old version of a VAD
How to install an old version of a VAD

@ConorSheehan1: The Virtuoso Faceted Browser is the easiest means of publishing RDF Linked Data in Virtuoso with dereferenceable URIs with HTML description pages (and different serialisation formats) automatically generated for all entities loaded in the Virtuoso RDF Quad Store.

In your case you seem to what to have dereferenceable URIs for any subject URI returned from a SPARQL query run against the Virtuoso /sparql endpoint, ie http://{cname}/place/411 in your example. But what is the HTML view you are seeking from such URIs? As that would need to be defined, and a combination of Virtuoso URL Rewriting and Content Negotiation used to generate the necessary dereferencable Linked Data URI HTML (and other serialisation format) pages.

Below are links to documents defining the process in more detail:


what is the HTML view you are seeking from such URIs ?

I don’t really mind. A turtle representation would be fine. Something like this:
Or a full webpage line this:

I had a look at the Facet Browser Installation Instructions but neither path worked for me. All I see in the packages menu of virtuoso is conductor and iSPARQL.

I had to build virtuoso from source, since I need to use the 7.x series, but 6.x is the latest available version I can apt-get. I tried downloading the VAD from here as the docs suggest. I ran the install script, but I still don’t see the fct package or the facet browser. It seems to have generated more scripts which would install an entirely new version of virtuoso, which isn’t what I’m looking for.

Is there any other documentation for installing the facet browser within an existing installation of virtuoso that doesn’t have the fct package available?


Click here for the Faceted Browser VAD.

Please let us know if it resolves your problem.


Ah sorry I didn’t notice the tab at the top for selecting VADs. That worked perfectly!



As noted in your second thread about this VAD, the links provided above get you the FCT VAD for Enterprise Edition v8.2.

Since you’re running a self-built Virtuoso Open Source Edition (VOS) v7.2, you need a different FCT VAD – which was built for VOS 7.2.