Virtuoso and visualization using LodLive: not work

Hi ,
I am trying to Visualize my ttl resource stored in Virtuoso (e.g., source: and later use my local Lodlive (http:// en . lodlive).
I ran the following steps installation:

Following steps, after installation:
(1)Load turtle dataset using Conductor “Quad Store Upload” (following virtuoso doc url=

3) The inserted triples by executing the following statements (it seems to work fine):

Finally, test in Lodlive what happens:
The problem verified when I run the following url in my browser:
Url =
See image below: is “Resource not found

Instead the correct visualization should be the following when the resource is found in virtuoso is:

Any suggestions are welcome …
Thanks in advance

Hi @pina_palmieri ,

The issue here is that you’ve loaded your RDF Triples into a Named Graph and then assumed that Named Graph IRI is directly accessible via HTTP. That isn’t the case.

Based on what you’ve done so far, you could make a SPARQL CONSTRUCT or DESCRIBE query from your endpoint and then pass that URL onto LODLive.

Alternatively, you could simply store the RDF-Turtle document to Virtuoso’s WebDAV repository and then use HTTP directly to access the RDF, as per you original approach.

I hope this clarifies matters.



Hi @kidehen ,
thank you very much for your suggestions, am i still have some problems.

I would first do the second of the tasks you suggested (i.e: “Alternatively, you could simply store the RDF-Turtle document to Virtuoso’s WebDAV repository and then use HTTP directly to access the RDF, as per you original approach.”).
I am following this documentation: HTTP PUT Example 2

  1. Can you confirm that it is the right documentation?
  2. Unfortunately, following the steps of the documentation, this error appears (see screenshot )

Any suggestions would be greatly appreciated.

You can simply upload an RDF-Turtle document to a WebDAV folder via the Conductor UI. You don’t need to revert to HTTP PUT in this scenario.


  1. Goto Web Application Server | Content Management menu
  2. Click on “Upload” button in the WebDAV File Manager UI
  3. Copy URL of the Turtle doc to clipboard
  4. Pass URL to LODLive


Hi @kidehen,
thanks very much, I’m sorry but I still have a little problem.

When I am trying to upload a RDF-Turtle file, I’m getting this error message:

My conductor package updated to the version 1.00.8733.

Any suggestions?

Where did you obtain the indicated updated 1.00.8733 conductor from ?

Also, what it the version and gitid of your Virtuoso binary which can be obtained by running one of the following command from the “bin” directory of your Virtuoso installation:

virtuoso-t -? for Open Source

virtuoso-iodbc-t -? for Commercial

I assume you are using Open Source which on testing with the latest Conductor VAD 1.00.8786 works for me and I can upload TTL RDF file and query if via the Virtuoso SPARQL endpoint from WebDAV folder for type Linked Data Import , thus please try with this version.

Hi @hwilliams,
thanks very much for your support.

I give you more details to your questions:
(Q1) Where did you obtain the indicated updated 1.00.8733 conductor from?

This information has been read from the available packages listed in the Install Packages section of the System Admin → Packages tab of the Virtuoso Conductor. (please, see attached screenshot)

(2) Also, what it the version and gitid of your Virtuoso binary…
I installed an “OpenLink Virtuoso Open Source Edition 7.2 Docker Image” and to check the version of the virtuoso binary, I used the following command:

docker run openlink/virtuoso-opensource-7 version

What do you suggest I do, since I work with docker of virtuoso images?
I found this updated “Docker container running Virtuoso | Matteo Lissandrini @ AAU” .
can these updates solve my problem?

Any suggestion would be appreciated.

I started a local Virtuoso 7 Open Source docker image and get the same SR185: Undefined procedure DB.DBA.ACL_VALIDATE error trying to create a DAV folder using the 07.20.3230-pthreads for Linux as of Feb 4 2020 latest binary and even when updating conductor VAD so the problem appears to be in the binary itself, which will be reported to development to fix.

Do you specifically want/need to import RDF data via WebDAV or can you uploaded via the Conductor Linked Data -> Quad Store Upload tab or using the RDF Bulk loader if you have many files ?

Hi @hwilliams ,
For now, I need no need to upload large amounts of RDf documents, so i could wait for the issue to be resolved and if, please can you notify me.
Instead I have to make Virtuoso and LodLive talk at least with a simple example.
In the previous post (Virtuoso and visualization using LodLive: not work) , I had described the problem in detail, used Linked Data → Quad Store Upload tab,

  1. Uploaded rdf - ttl document

  2. Finally, test in Lodlive what happens:
    The problem verified when I run the following url in my browser:
    Url = ?
    See image below: is “ Resource not found

What am I doing wrong?
Thanks in advance for you help

Can you goto and query the RDF Graph you loaded ie , which I suspect you can in which case Virtuoso has loaded your RDF data into its RDF Quad Store successfully, but this is not automatically accessible on that IRI.

I have not used Lodlive before but going to their test server ie LodView — giving data a new shape you can enter a resolvable LOD IRI like and it loads and provides its alternate visualisation. Whereas is not resolvable IRI, as it is a Virtuoso internal graph name so would not load in Lodlive. They have an optional SPARQL endpoint URI that can be provided with the IRI, which I would hope when then assume the IRI is a graph IRI and query it against the endpoint, but it appears not. The LodLive document is poor to you would have to ask them how it is suppose to work.

Other than that if the data is loaded into a publicly accessible DAV folder as @kidehen suggested then you should be able to pass that a resolvable IRI to LodLive which should then be able to create a visualisation for it, but would need the docker image DAV folder creation issue be resolved …


RDF can be imported into Virtuoso using the SPONGER via SPARQL. Once in place, a DESCRIBE Query URL is all that needs to be passed to LOD Live.

DEFINE get:soft "soft"

WHERE {?s ?p ?o}

The you simply execute DESCRIBE or CONSTRUCT queries where the results URL is passed on to LODLive.

DEFINE sql:describe-mode "CBD"

FROM <RDF-Document-URL> 
WHERE {?s ?p ?o}


CONSTRUCT {?s ?p ?o}
FROM <RDF-Document-URL> 
WHERE {?s ?p ?o}

Hi @hwilliams ,
Thank you for your prompt reply.
I still need some suggestions:
(1) The docker image DAV folder creation issue, are there any predictions when it will be fixed?
If the times will be very long to solve the issue, maybe it is the case that I re-install virtuoso without using the docker image?
In the meantime, I’m also analyzing @kidehen suggestions .

Hi @kidehen ,
Thanks very much for your suggestion
I have no experience with Virtuoso Sponger.
I’m documenting (I’m reading your post ).
I hope that in my Virtuoso Docker there is no problem.

Will have to check with development when they will be able to fix this issue in the docker images, but in the meantime you can use one of the standalone Virtuoso 7 open source binaries

Hi @hwilliams,
thanks for your attention, I try the software like you suggested.

Hi @hwilliams ,
sorry but I have problem installing virtuoso-opensource (develop/7) checking out from Github (see screenshot below)


I have been following instructions from GitHub - openlink/virtuoso-opensource: Virtuoso is a high-performance and scalable Multi-Model RDBMS, Data Integration Middleware, Linked Data Deployment, and HTTP Application Server Platform to install Virtuoso.

I checked the version of my Virtuoso binary:

I am unable to start the conductor services, follow error in screenshot:

Here a screenshot of my local virtuoso


Any suggestions are welcome.

Not sure what Linux distro you are seeking to use, but would assume some older Ubuntu or Debian distro which bundled an old Virtuoso 6.x version, which you seem to have somehow picked up in however you are seeking to start the Virtuoso instance. Also not sure why you appear to compiling Virtuoso when I pointed you to standalone Virtuoso 7 open source rebuilt binaries ?

Anyway, the issue with the Virtuoso 7 Open Source docker image has been resolved and a new Conductor VAD 1.00.8823/ 2021-04-12 with fix available, allowing document to be successfully uploaded to DAV.

Hi @hwilliams,
great news regarding the fixed issue with Virtuoso 7 Open Source docker image, I’ll give it a try now.
Thank you for taking your time and I’m very appreciative of all the support you’ve given me.

Best regards