RDF Bulk loader for N-Quad files not loading


#1

Hi,

I’m trying to load this ~100MB N-Quad dump into Virtuoso by uploading it dba’s rdf_sink folder (I tried both compressed and uncompressed). I waited 30 mins but no data was loaded. I get this when I check the status of bulk loader some time after upload, per these instructions:

select * from DB.DBA.LOAD_LIST where ll_error IS NOT NULL

Enter password for dba :
Connected to OpenLink Virtuoso
Driver: 07.20.3217 OpenLink Virtuoso ODBC Driver
ll_file                                                                           ll_graph                                                                          ll_state    ll_started           ll_done              ll_host     ll_work_time  ll_error
VARCHAR NOT NULL                                                                  VARCHAR                                                                           INTEGER     TIMESTAMP            TIMESTAMP            INTEGER     INTEGER     VARCHAR
_______________________________________________________________________________


0 Rows. -- 1 msec.

The article mentions bulk_load.sh script, but I do not find it under /opt/virtuoso/bin. I verify that RDF bulk loader is working, since it did load this smaller N-Triples file (compressed and uncompressed).


#2

@Sherman_Monroe: I am not sure why you expect to upload file to an “rdf_sink” folder and check the status of the load_list table to determine if they have loaded, as this is a WebDAV feature, enabled as detailed here.

The load_list table is only used by the Virtuoso RDF Bulk Loader, for which the datasets have to be placed in a file system location accessible to the Virtuoso server and one or multiple “rdf_loader_run()” command run to bulk load the file loaded into the load_list table for load with the ld_dir() command as detailed in the documentation for the bulk loader above.

For loading of large datasets the Virtuoso RDF Bulk Loader method should be used …


#3

Hi Hugh,

Thank you, I will keep this in mind. I’ll try loading the file directly onto the Virtuoso server and using the Bulk Loader feature…


#4

That worked. We now have classes and properties for use by the Forms editor!