Permissions on LDP Containers and Resources

ldp

#1

Hi all,

I notice that the permissions on LDP resources and containers that I create using PUT are not the same as their parent “folder”. I would prefer everything to be publicly readable, and i can set that on the top-level folder, but Containers that I create inside of that (and inside of those) not not inherit the ‘r’ permission for all.

Is there a way to force the new containers/resources to carry their parent permissions?

Mark


#2

Fastest and easiest way to resolve this, given that your intended parent directory exists now, is to visit the ConductorWeb Application ServerContent Management, and locate your intended top-level container.

Click the properties icon, and locate the menu for Permissions Inheritance (new label) or Default Permissions (old label).

This menu defaults to Off. Select Recursively for your desired effect.

(Direct members would apply this container’s permissions only to resources created directly within this container – not to resources created within sub-containers of this container.)

Please let me know if this is satisfactory.


#3

Yes, that’s what I thought too… but ‘recursively’ isn’t recursive. It only works for the first level of “children”. Not beyond that.


#4

When you changed the Permissions Inheritance setting, did you also tick the box for Apply changes to all subfolders and resources to apply it recursively to all existing containers in the container you edited?

What is the full version of the Virtuoso binary you’re running? Please provide the full first stanza (above “Usage”) of output from virtuoso-t -? for VOS, or virtuoso-iodbc-t -? for Enterprise Edition.

Please also provide full output of this SQL query –

vad_list_packages ();