Numeric value out of range for <temporary space column>


testing on virtuoso-opensource- on windows

One of sparql query with average logic given this error :

Virtuoso 22003 Error SR128: Numeric value out of range for temporary space column (0, 40)

same query works fine on high end ubuntu machine

Please let me know any parameter of virtuoso config can tweak to make this work ?


What is the actual SPARQL query being run ?

@hwilliams thanks for replying
this is query for understanding :

SPARQL SELECT (AVG(?o2) AS ?oGroupByOUT) (?s0) {
SELECT DISTINCT (?s0) (?o0) (?o2)
?s0 rdf:type
?o0 ?s0.
?o0 ?o1.
?s0 rdfs:label ?s0Name.
BIND(xsd:decimal(?o1) AS ?o2)
GROUP BY (?s0) (?s0Name)
LIMIT 1000000

Just for testing purpose if in SUBQUERY we put LIMIT 2000000 then query output comes
if we increase to LIMIT 3000000 or do not give limit then error comes
SQLState: 22003

Message: SR128: Numeric value out of range for (0, 40)

1 Like

What is the Virtuoso version being used ?

Are you saying the error also occurs with LIMIT 1000000, works with LIMIT 2000000 and fails LIMIT 3000000 or above ?

If the GROUP BY (?s0) (?s0Name) is removed does the error still occur ?

virtuoso-opensource- on windows

even group by is removed then still same error

outer limit not much relevant

there is inner query which is doing distinct in that
tried putting limits in inner query for testing and control data to see behaviour :

LIMIT 2000000 in inner query then whole query works
LIMIT more than 2000000 in inner query then same error comes

this tells due to volume of data in inner query, issue is happening in average logic

Possible we tweak some virtuoso parameters which can make query work for full volume ?

I asked for the specific Virtuoso version details as specified in the link, as virtuoso-opensource- doesn’t mean much other than you seem to be running a relatively old version from back in 2016. In which case the recommendation would be to upgrade to the latest Virtuoso 7.2.13 release from Jun 2024, the Windows installer for which is available from Virtuoso_Open_Source_for_Windows.exe and see if the problem persists.

tried above case on
OpenLink Virtuoso Universal Server
Version 07.20.3240-threads for Win64 as of Jun 10 2024 (a1fd8195b)

same error coming
Looking at type of problem
If can suggest some parameters of virtuoso.ini which can try increasing to see if it works

There are no INI file or other configurations params/settings that can be set to avoid the error. You should check the values of ?o1 in the query or check if the query runs w/o the distinct in it.

If you are still having problem can you provide a test case for recreating such that we can look into to determine the cause ?