Installing Virtuoso on AWS (BYOL)

Hello @hwilliams ,
I have followed the steps detailed here but when i try to administer virtuoso via ssh i keep getting connection time out: connection lost and I could not even access the public IP on my browser. find screenshot below

Assuming the IP address indicated ie is external IP assigned to the AMI instance , does the AWS security group assigned to the instance allow access to the ssh port 22 , as the Connection time out error implies either the IP address or port 22 are not accessible from your location.

For a BYOL instance the Virtuoso server is not started by default when the AMI is instantiated as there is not license file in place for use, which is why a valid license file first needs to be moved into place and then the Virtuoso service enabled and started. At which point it would be accessible via HTTP on port 8890 provided the security group allows access to the port, as per the documentation.

As @hwilliams already asked, do you have a configured and functional security group for using TLS/HTTPS to communicate with your virtual machine instance? Put differently, can you use scp with any other AWS virtual machine?

Your timeout error is indicative of firewall protection effects associated with the TLS port and the potential lack of inbound connection rules described in a security group.

I have a security group configured with inbound rules (port range and protocol set to All)

And you can’t use ssh to successfully login into that AWS virtual machine?

No, I can’t, and I followed the steps detailed in this document

I can now login successfully using SSH.
I discovered that the public key I was using was not accessible and I was not running the command prompt as an administrator, after fixing both, the connection was successful.

Okay, good to see you are making progress :slight_smile:

1 Like

Hello @hwilliams, is there another way of setting the db password,as I am not able to type anything after entring this command “isql 1111”. I tried entering a password but nothing is showing on the screen, I have tried this multiple times and getting smae issue.


What is the password you are entering ?

Are you using the random password that should have been set when the database was created and accessible with sudo cat /opt/virtuoso/database/.initial-password file, as detailed in the Amazon OpenLink Virtuoso Ubuntu BYOL AWS AMI documentation.

When I type, I don’t see any anything on the screen showing, well, on the UI I use the random password set initially to log in and it was successful, just on the command it shows nothing when I try inputting the password.

Thanks @kidehen and @hwilliams for the help, installation is completed and running fine.

You first login with the default random dba user password via isql and then use the set password <old password> <new password> command to change the password, via command line, to one of your choice as detailed in the Default Passwords section of the documentation. Or you can use the Virtuoso Conductor Administration Interface and change the password via the browser based UI.

1 Like

Thanks @hwilliams for the response.