How make a graph visibile only to administrato dba dba and not visible through endpoint


Im working with Openlink Virtuoso Version: 07.20.3230

through this link Virtuoso Features Comparison Matrix

I can see that it is possible to apply acls, but through the endpoint esposed I can still see the graph even i restarted the virtuoso service.

This is the ACL that i defined in the virtuoso.ini is the following

DefaultACL = (
( ALLOW SPARQL, DAV:all, “user:dba” ),

Any suggestions why it doesn’t work?

What are these DefaultACL settings you indicate having added to the INI file ie

DefaultACL = (
( ALLOW SPARQL, DAV:all, “user:dba” ),

suppose to do, as I don’t know of any such INI file or other setting in Virtuoso ?

Based on your Virtuoso version 07.20.3230 I assume you are using the Virtuoso open source product, which case you can use the Virtuoso Graph Group Security functionality to make any graphs private by adding them to the special graph group, making them only accessible by the dba user as detailed in the documentation.

Thank you,

I created the group through this command because isql was saying to me that it was not available


Thus I inserted my graph e.g. ‘example_graph_uri’

DB.DBA.RDF_GRAPH_GROUP_INS (‘’,'example_graph_uri’)

and ISQL says “The statement execution did not return a result set.”

But when i query over the private graph, it exists but is empty and from the endpoint data are visibile

Any other suggestions?

Thank you in advance

I don’t understand what you mean by the statement above, as if the graph is empty, what data is visible via the SPARQL endpoint ?

Thank you, at the end it worked. I did again all by scratch and now the private graph is queryable only by dba