Couldn't start load TTL on virtuoso-opensource-7 docker image


#1

Hi, I am new to Virtuoso, and I just got an extraction of TTL files from DBPedia.

I used docker-compose to start the image openlink/virtuoso-opensource-7 with my TTL folder as a volume for the container:

version: "3.7"
services:
  dbpedia-virtuoso:
    image: openlink/virtuoso-opensource-7
    environment:
      - DBA_PASSWORD=dba
    ports:
      - 8890:8890
      - 1111:1111
    volumes:
      - /home/user/myttl:/database

Then I entered the container with isql and tried:

ld_dir('.', '*.tll', 'http://localhost:8890/DAV');
rdf_loader_run();

After waiting some time I try to see any extraction and no results:

SQL> select * from DB.DBA.LOAD_LIST;                           
ll_file                                                                           ll_graph                                                                          ll_state    ll_started           ll_done              ll_host     ll_work_time  ll_error
VARCHAR NOT NULL                                                                  VARCHAR                                                                           INTEGER     TIMESTAMP            TIMESTAMP            INTEGER     INTEGER     VARCHAR
     _______________________________________________________________________________


0 Rows. -- 1 msec.

Does anyone know what am I doing wrong?


#2

Have you set theVirtuoso DirsAllowed INI file param to allow the Virtuoso server to access the location of the TTL files for loading, as detailed in the prerequisites section of the RDF Bulk Loader documentation ?


#3

Yes @hwilliams, the directory is allowed. Interestingly when I tried to change http://localhost:8890/DAV to ld_dir (’.’, ‘*.ttl’, ‘http://dbpedia.org’); as in the documentation example it started to load. But now one of my turtle files are giving the error:

./ptwiki-20190120-mappingbased-objects-uncleaned.ttl http://dbpedia.org 2 2019.2.16 16:22.5 96188000 2019.2.16 16:22.6 684588000 0 NULL 37000 [Vectorized Turtle loader] TURTLE RDF loader, line 172395: SP029: TURTLE RDF loader, line 172395: syntax error


#4

The graph name specified in ld_dir() are irrelevant and can be any string value, http://dbpedia.org is used in the doc as the actual DBpedia datasets where being loaded in the example.

Have you check line 172395 of the ./ptwiki-20190120-mappingbased-objects-uncleaned.ttl dataset file (or lines before) to ensure they are valid ? Also, have you check the ttl file itself with a turtle validator to ensure it is valid ?


#5

@hwilliams do you recommend any turtle validator?

The line of that file seems ok: <http://pt.dbpedia.org/resource/Reino_de_Roma> <http://dbpedia.org/ontology/governmentType> <http://pt.dbpedia.org/resource/Monarquia> <http://pt.wikipedia.org/wiki/Reino_de_Roma?oldid=53119289&ns=0> .