CORS rule not persisting

cors
virtuoso

#1

Hi,

I followed the instructions here to enable CORS. I set the CORS pattern to a single asterisk char. I click “Finish” and it pushes me to the “Publish Objects” tab. When I exit and visit the “Authentication” tab again, the CORS field is empty, and also, my AJAX call returns error

VM145:1 Access to XMLHttpRequest at ‘localhost:8890/service/fct’ from origin ‘http://myopenlink.net’ has been blocked by CORS policy: Cross origin requests are only supported for protocol schemes: http, data, chrome, chrome-extension, https.

Here is what I tried:

  • Tried this on latest VOS and Virtuoso 8.2, same on both

  • Tried next-ing through the “Web Service Endpoint” wizard, starting from the “Virtual Directory Information” tab and the “Authentication” tab, same both times

  • Tried clicking “Save Changes” button on the “Publish Objects” tab, and get the following error "SQ074: Line 1: syntax error at ‘SPARQL’ before ‘SELECT’:

image

Any advice would be greatly appreciated.

-sherman


#2

Hi Sherman,

Development is aware of this issue and i am actively seeking a resolution from them.

I will advice you as soon at a fixed conductor is available.


#3

10-4, thank you Patrick!